当前位置:首页 > 问答

通达信xt未来函数预警指标

我来帮TA回答

请高手帮忙把这个指标公式改为通达信预警选股公式。顺便高手看看是否有未来函数。先谢谢老师了。

{n:=???{自添},无未来函数,出现红柱准备买入,如下}
----------------------

VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1);
VAR2:=8;
CROSS(VAR1,VAR2);

老师,以下公式若无未来函数,请改成通达信预警公式,并加上条件KD的k值小于50

奇怪,本来就是通达信的选股呀,没啥需要改的呀。
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
买入:IF(FILTER(MR,10),1,0)AND K<50;

哪位高手能把这个通达信指标公式改为预警公式

如果你懂得看程序语句的话,可以看出绝大多数语句与你的要求无关。买入条件句是:
买入: REF(VAR1,2)>REF(VAR1,1) AND VAR1>REF(VAR1,1)
而其中只有一个变量 VAR1,往上一行就找到它的语句:
VAR1:=ZIG(CLOSE,13);
这个语句只用到一个参数,就是收盘价。所以买入选股公式只有两行,就是:
VAR1:=ZIG(CLOSE,13);
买入: REF(VAR1,2)>REF(VAR1,1) AND VAR1>REF(VAR1,1);
放到预警中使用时,好像只能对日线,不能对60分钟和15分钟。
在这里我特别提醒你,由于公式用到未来函数,用于选股不合适。请你在网上以“未来函数”来搜索一些资料看一下,多了解些情况,不要用自己的钱去作试验。

谁有准确率高的t加0的选股公式加预警。通达信的。不含未来函数。

我通达信的没有,但有同花顺的

求编写通达信软件的选股公式,要求当天突破箱体的箱顶,并且是跳空或者大阳线突破

你看这样的思路行不:
{60日MA线基本走平,前60个交易日,收盘3次接近60日内最高价,但未能突破,最后交易日股价突破60日内最高价幅度5%或者开盘高开3%}
CHHV:=CONST(HHV(C,60));
MAHHV:=CONST(HHV(MA(C,60),60));
MALLV:=CONST(LLV(MA(C,60),60));
BETWEEN(MAHHV/MALLV,0.95,1.05) &&
COUNT(BETWEEN(C,CHHV*0.95,CHHV),60)>3 &&
(C/CHHV>1.05 || L/REF(H,1)>1.03);

请大师在您的这个(通达信)突破大箱体指标基础上再加上一个条件,谢谢啊!!!!

KK:=IF(H=HHV(H,3),H,L);
KK0:=CONST(MAX(TROUGHBARS(KK,15,1),PEAKBARS(KK,15,1)));
前期大箱顶:IF(CURRBARSCOUNT<KK0+2,CONST((PEAK(KK,15,1))),DRAWNULL);
前期大箱底:IF(CURRBARSCOUNT<KK0+2,CONST((TROUGH(KK,15,1))),DRAWNULL);
STICKLINE(CURRBARSCOUNT<KK0+2,前期大箱顶,前期大箱底,5,0),COLOR882266;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
涨幅大于5%:EXIST((C-REF(C,1))/REF(C,1)*100>5 AND C>PEAK(KK,15,1),5),NODRAW;
成交量大:REF(V,BARSLAST(涨幅大于5%))>REF(V,PEAKBARS(KK,15,1)),NODRAW;
先做两个条件:DRAWICON(涨幅大于5% AND 成交量大,L,13);
XG:C>=HHV(REF(C,1),120),NODRAW;
STICKLINE(CONST(SUMBARS(XG,1))=CURRBARSCOUNT,L*0.98,L*0.97,4,0),COLOR00FFFF;
DRAWTEXT(CONST(SUMBARS(XG,1))=CURRBARSCOUNT,L*0.95,'新'),COLORFFFFFF;
DRAWTEXT(CONST(SUMBARS(XG,1))=CURRBARSCOUNT,L*0.92,'高'),COLORFFFFFF;
{(1)过去5天之内有一根涨幅大于5%的大阳线突破前期大箱体的最高价;
(2)这根大阳线当天的成交量大于前期大箱体最高价的那根成交量;
(3)这根大阳线的收盘价与突破点的幅度大于3%;
(4)前期大箱体的最高点和最低点幅度在30%以内;
(5)前期大箱体的天数为60天(大阳线往前数60天,不包括大阳线本身这天);
(6)最近10日有一根涨幅大于3%的阳线,而且该阳线的最低价与最近20天的最低价比值在0.98-1.02之间。
(7)最近3日的量持续萎缩。
(8)今日收盘价与前期箱体最高价的比值小于1,大于0;};